Acronis Cyber Protect Cloud: Backup fails with warning "Not enough memory"

Acronis Cyber Protect Cloud: Backup fails with warning "Not enough memory"

Symptoms

Backup fails with a warning: Not enough memory

Cause

Reasons may wary. Requires troubleshooting on the Agent machine.

Troubleshooting

  1. Open Windows event logs (Start -> in Search, type eventvwr.exe and press Enter) and navigate to Windows Logs -> System
  2. Filter by "Warning" and event source "Resource-Exhaustion-Detector"
  3. Locate the event (id 2004) that occurred during the backup and check the event contents:
    We recommend 1 GB RAM for 1 TB of archive size.
    • If the highest consumption is by service_process.exemms.exe or other Acronis process (act.exe, aakore.exe, etc.) and it exceeds the recommended RAM - escalate to Acronis support.
    • If the highest consumption is by service_process.exe and it's below the recommended RAM - check the available RAM, increase it, or lighten the load on the system 
    • If the highest usage is not by Acronis service - address the high usage issue based on which service reports it or increase RAM

More information

Error "Not enough memory" during agentless VM backup is usually caused by insufficient RAM on Virtual Appliance: about 1 GB RAM per 1 TB of archive size is required for proper backup operation. Increase RAM on the Virtual Appliance to resolve the issue.