Acronis Cyber Protect Cloud: Backup fails with "Failed to parse the XML"

Acronis Cyber Protect Cloud: Backup fails with "Failed to parse the XML"

Symptoms

The backup of any kind fails with the following error message:

Failed to parse the XML.

| error 0x3b0001: Failed to parse the XML.
| line: 0x9a79f20828bcab0
| file: e:\72\enterprise\mms\managers\location\impl\manager.cpp:832
| function: LocationManagement::LocationManagerImpl::AddLocation
| IsReturnCode: 0x1
| $module: disk_bundle_vsa64_4670

Cause

Make sure that the error message states the following faulty function: LocationManagement.

The issue happens when the backup process cannot parse the XML file that is used to store information about Location (destination of the backup).

Solution

The issue can be solved by generating a new "locations" file.

Open C:\ProgramData\Acronis\BackupAndRecovery\MMS\Locations. If you have more than one destination, you would have several files in this folder. Each file stores information about one destination. Open them one by one in a text editor. If a file is an unreadable set of symbols, it is damaged:

To regenerate the file:

  1. Stop Acronis Managed Machine Service: Win+R -> type services.msc -> locate Acronis Managed Machine service and click Stop service.
  2. Delete the C:\ProgramData\Acronis\BackupAndRecovery\MMS\Locations\<name of the damaged file>
  3. Start Acronis Managed Machine service.

Retry backup, a new XML file will be generated.

More information

Possible causes of the damage could be:

  • malware such as scanners, viruses, cryptolockers
  • bad blocks of the HDD
  • unexpected power outages
  • faulty hardware such as connectors, ports, jacks etc.